Scheduled Maintenance: Presence
Incident Report for Discord
Resolved
Maintenance complete. Thank you for the patience. It was a big success!

For the first time in Discord's history, we were able to test the full recovery of our presence cluster in under 5 minutes, and full node recovery in under 2 without a full cluster reboot.
Posted Jan 08, 2020 - 23:14 PST
Monitoring
We are currently undergoing scheduled maintenance to our presence cluster - in order to address recent stability issues. No impact to message sends in DMs should be observed, however, the following will be impacted:

- Status of your friends may be incorrect (people will appear offline).
- Typing events in DMs are currently not being dispatched.
- Push notifications will deliver even if you're active on a desktop client.
Posted Jan 08, 2020 - 22:51 PST